gt250/gt500 oil pump question

Everything you want to know about oil but were "afraid to ask"!

Moderators: Suzsmokeyallan, oldjapanesebikes, H2RICK, diamondj

User avatar
dorT500
To the on ramp
Posts: 253
Joined: Mon Jun 12, 2017 12:01 pm
Country: USA
Suzuki 2-Strokes: '75 T500M since '93 Ridden it over 100,000 mi
Location: Galveston County, Tx.

Re: gt250/gt500 oil pump question

Post by dorT500 »

I think I read in this forum an old thread about how someone was having some type trouble with his oil pump after he had disassembled it and put it back together. Long story short, I think this is what he discovered he had done and lining it all back fixed the problem. I'm not trying to be vague, I'm just going by memory and I think I ran into this little hitch years ago also the first time I put a pump back together.

Anyway, I just typed up this little warning just as a' heads up' for those not as familiar with the pump as others. You can also look down the plunger guide's screw hole and see if the low side of the ramp is up so that guide screw's 'roller' will ride nicely at the end of the plunger. You can of course spin the pump a bit as needed to align.


Image
_____________
______________________
_______________________________
GONE.......WITH A PUFF OF SMOKE AND A BLUR OF SPOKE
User avatar
dorT500
To the on ramp
Posts: 253
Joined: Mon Jun 12, 2017 12:01 pm
Country: USA
Suzuki 2-Strokes: '75 T500M since '93 Ridden it over 100,000 mi
Location: Galveston County, Tx.

Re: gt250/gt500 oil pump question

Post by dorT500 »

Hey dollydog,

Well, it looks like this has been discussed before. Just happened on this old thread...

viewtopic.php?f=6&t=12233" onclick="window.open(this.href);return false;" onclick="window.open(this.href);return false;
_____________
______________________
_______________________________
GONE.......WITH A PUFF OF SMOKE AND A BLUR OF SPOKE
Post Reply