Suzuki2Strokes.com

Sundial Moto Sports

Suzuki Two-Stroke Message Board
Suzuki2Strokes.com
It is currently Tue Dec 11, 2018 8:49 am

All times are UTC - 6 hours




Post new topic Reply to topic  [ 17 posts ]  Go to page Previous  1, 2
Author Message
PostPosted: Sat Aug 18, 2018 6:34 am 
Offline
On the street

Joined: Sun May 06, 2012 5:40 am
Posts: 16
Country: australia
Bikes owned: t250
tank


Attachments:
39507024_327551694655808_6155571975013007360_n[1].jpg
39507024_327551694655808_6155571975013007360_n[1].jpg [ 216.42 KiB | Viewed 246 times ]
Top
 Profile  
 
PostPosted: Mon Dec 03, 2018 7:29 am 
Offline
On the main road
User avatar

Joined: Mon Nov 25, 2013 1:16 pm
Posts: 121
Location: Perth, Western Australia
Country: Australia
Bikes owned: T250, GS550, TL1000S, T500 race, GSXR400 race
Ben, did you ever get this to rev properly? If so what was the issue? I had a similar problem (not quite so pronounced) with mine in the early days and it ended up being pipe dimensions. I also found to my surprise as we retarded the ignition timing (Zeeltronics) it kept making more power.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 17 posts ]  Go to page Previous  1, 2

All times are UTC - 6 hours


Who is online

Users browsing this forum: No registered users and 22 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Sundial Moto Sports forum © by Eric F. Kalamaja
Suzuki2Strokes.com