Suzuki2Strokes.com

Sundial Moto Sports

Suzuki Two-Stroke Message Board
Suzuki2Strokes.com
It is currently Mon Aug 20, 2018 6:43 pm

All times are UTC - 6 hours




Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Sat Oct 18, 2014 5:48 pm 
Offline
Around the block
User avatar

Joined: Wed Sep 24, 2014 8:00 am
Posts: 66
Country: USA
Bikes owned: '75GT750, '79CX500, '08ZX-14
Picked this bike up a few months ago, not running, leaking, frame looked like a Cheet-O there was so much rust. It's been a work in progress up to this point and I'm having a set of Jemco pipes made up right now. I need to still sort out the turn signals/brake light situation. I know cutting up a GT750 is not for everyone but alot of the frame had cancer rust (to include the rear subframe. As you can see from the original pic, alot of parts were missing and as you all know, tracking that stuff down is tough.

The stock oil tank was cracked and leaking so I used an automotive catch can (for now anyways). I tackled the usual gripes like the water pump seal, gear indicator switch seals, etc. Paint is GM Charcoal Silver. I love this bike, the power hits hard and that 2-stroke sound is so addicting. I'll update with a new pic when the pipes arrive.
Image
Image
Image
Image
Image

The information on this board is invaluable and I appreciate everyone's posts on here.


Top
 Profile  
 
PostPosted: Sat Oct 18, 2014 7:03 pm 
Offline
AMA Superbike

Joined: Tue Jul 24, 2012 11:45 pm
Posts: 1681
Location: SW PA
Country: U.S.
Bikes owned: 75- GT 550 / 76- GT 750
That first picture is funny to me. That condition is nearly exactly how mine looked when strapped in the back of my truck when I picked it up. Same missing cover, tank condition etc. Except, mine had a lot more rust. It's ok, to use that as an excuse for doing what you want to the bike, lol !

_________________
Image Image


Top
 Profile  
 
PostPosted: Sun Oct 19, 2014 11:16 am 
Offline
Around the block
User avatar

Joined: Wed Sep 24, 2014 8:00 am
Posts: 66
Country: USA
Bikes owned: '75GT750, '79CX500, '08ZX-14
Yeah I waited for a long time for one of these to pop on my local craigslist. The rust has been an ongoing issue but for now, the bike drives, stops and handles great.

The tank was a challenge, I almost scrapped the thing a few times but luckily it was brazed and lined. Holding gas for now!


Top
 Profile  
 
PostPosted: Sun Oct 19, 2014 10:53 pm 
Offline
AMA Superbike

Joined: Tue Jul 24, 2012 11:45 pm
Posts: 1681
Location: SW PA
Country: U.S.
Bikes owned: 75- GT 550 / 76- GT 750
I drove all the way to Maine from Pa to find the deal I was looking for. Decent to good quality tanks pop up on Ebay quite often. If yours is bad as it may be. I'd be shopping. But, if there isn't leaks from pin holes. It should be refurbish able. POR 15 is the way to go. I see you went with same China piggy back shocks. How do you feel about them ? Myself, I like mine a lot. I was able to improve ride height quite a bit and the bike handles so much better now. Mine sits a tad high. But, when I sit on it the sag is perfect for me. What's the deal with the bottle mounted to the side of your frame ? Here's a vid of my restoration. https://www.youtube.com/watch?v=UQNZhzc ... ww&index=5

_________________
Image Image


Top
 Profile  
 
PostPosted: Mon Oct 20, 2014 6:00 am 
Offline
Around the block
User avatar

Joined: Wed Sep 24, 2014 8:00 am
Posts: 66
Country: USA
Bikes owned: '75GT750, '79CX500, '08ZX-14
The shocks are decent enough for me. They feel good on the freeway, don't sag and I like how I can adjust the height. I used the POR-15 liner on the tank and I have to say I was really impressed by the product. I also POR-15'd the underside, and chassis-cote blacked over that.

The bottle on the side is an automotive catch-can I got off summit racing. I'm using it as the injection oil tank. My old plastic tank had a big crack in the bottom, and I couldn't find any affordable side covers so I'm going with this tank for now. I really like the external sight tube on it, I'm pretty sure I saw this setup on another member's bike here somewhere.... so thanks whoever that was!

I moved all of the electronics up under the seat into a tray I made which also holds the battery. Everything's working good so far!

BTW awesome vid, how could it be bad when it's set to AC/DC haha.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 6 hours


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Sundial Moto Sports forum © by Eric F. Kalamaja
Suzuki2Strokes.com